[CMAKE]
[reactos.git] / drivers / video / font / ftfd / CMakeLists.txt
index 5682f11..72458f7 100644 (file)
@@ -1,22 +1,25 @@
 
-
-
 include_directories(${REACTOS_SOURCE_DIR}/lib/3rdparty/freetype/include)
 
+spec2def(ftfd.dll ftfd.spec)
+
 add_library(ftfd SHARED
     enable.c
     font.c
     glyph.c
     rosglue.c
-    sprintf.c)
+    sprintf.c
+    ${CMAKE_CURRENT_BINARY_DIR}/ftfd.def)
 
-set_target_properties(ftfd PROPERTIES LINK_FLAGS "-Wl,-entry,_FtfdEnableDriver@12 -Wl,--subsystem,native")
+set_entrypoint(ftfd FtfdEnableDriver@12)
+set_subsystem(ftfd native)
+set_image_base(ftfd ${baseaddress_ftfd})
 
 target_link_libraries(ftfd
-    ${CMAKE_CURRENT_SOURCE_DIR}/freetype.def
-    -lwin32k
     freetype
     libcntpr)
 
+add_importlibs(ftfd win32k)
 add_dependencies(ftfd psdk)
-add_livecd_target(ftfd reactos/system32)
\ No newline at end of file
+add_cd_file(TARGET ftfd DESTINATION reactos/system32 FOR all)
+add_importlib_target(ftfd.spec)