Create a branch for working on csrss and co.
[reactos.git] / hal / CMakeLists.txt
index 3d4b3b2..e767918 100644 (file)
@@ -1,8 +1,8 @@
 
-if((ARCH MATCHES i386) OR (ARCH MATCHES amd64))
+if((ARCH STREQUAL "i386") OR (ARCH STREQUAL "amd64"))
     add_subdirectory(halx86)
-elseif(ARCH MATCHES arm)
+elseif(ARCH STREQUAL "arm")
 #    add_subdirectory(halarm)
-elseif(ARCH MATCHES powerpc)
+elseif(ARCH STREQUAL "powerpc")
 #    add_subdirectory(halppc)
 endif()