[HAL] Implement amd64 BIOS call support
[reactos.git] / hal / halx86 / CMakeLists.txt
index 458e537..f4148eb 100644 (file)
@@ -5,7 +5,8 @@ add_definitions(
 
 include_directories(
     include
-    ${REACTOS_SOURCE_DIR}/ntoskrnl/include)
+    ${REACTOS_SOURCE_DIR}/ntoskrnl/include
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/fast486)
 
 function(add_hal _halname)
     cmake_parse_arguments(_haldata "" "" "SOURCES;COMPONENTS" ${ARGN})
@@ -18,14 +19,14 @@ function(add_hal _halname)
         foreach(_component ${_haldata_COMPONENTS})
             list(APPEND _haldata_SOURCES "$<TARGET_OBJECTS:lib_hal_${_component}>")
         endforeach()
-        add_library(${_halname} SHARED
+        add_library(${_halname} MODULE
             ${_haldata_SOURCES}
             ${CMAKE_CURRENT_BINARY_DIR}/hal.def)
     else()
         foreach(_component ${_haldata_COMPONENTS})
             list(APPEND _haldata_LIBS "lib_hal_${_component}")
         endforeach()
-        add_library(${_halname} SHARED
+        add_library(${_halname} MODULE
             ${_haldata_SOURCES}
             ${CMAKE_CURRENT_BINARY_DIR}/hal.def)
         target_link_libraries(${_halname} ${_haldata_LIBS})
@@ -76,5 +77,6 @@ elseif(ARCH STREQUAL "amd64")
         amd64/processor.c)
 
     add_hal(hal SOURCES ${HAL_SOURCE} COMPONENTS generic acpi apic)
+    target_link_libraries(hal fast486)
 
 endif()