Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / lib / 3rdparty / libxml2 / CMakeLists.txt
index 3da4e5b..c0586e2 100644 (file)
@@ -13,6 +13,7 @@ add_definitions(
     -D_DLL -D__USE_CRTIMP)
 
 list(APPEND SOURCE
+    buf.c
     c14n.c
     catalog.c
     chvalid.c
@@ -61,6 +62,5 @@ target_link_libraries(libxml2 oldnames)
 add_dependencies(libxml2 psdk)
 
 if(NOT MSVC)
-    add_target_compile_flags(libxml2 "-Wno-format -Wno-pointer-sign")
-    allow_warnings(libxml2)
+    add_target_compile_flags(libxml2 "-w")
 endif()