Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / lib / 3rdparty / libxml2 / CMakeLists.txt
index e8c3ea2..c0586e2 100644 (file)
@@ -1,7 +1,5 @@
 
-include_directories(
-    .
-    include)
+include_directories(include)
 
 add_definitions(
     -D__MINGW32__
@@ -15,6 +13,7 @@ add_definitions(
     -D_DLL -D__USE_CRTIMP)
 
 list(APPEND SOURCE
+    buf.c
     c14n.c
     catalog.c
     chvalid.c
@@ -61,3 +60,7 @@ list(APPEND SOURCE
 add_library(libxml2 ${SOURCE})
 target_link_libraries(libxml2 oldnames)
 add_dependencies(libxml2 psdk)
+
+if(NOT MSVC)
+    add_target_compile_flags(libxml2 "-w")
+endif()