Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / lib / inflib / CMakeLists.txt
index bd629b7..418b454 100644 (file)
@@ -1,15 +1,29 @@
 
-set(GLOBAL_FILES infcore.c infget.c infput.c)
+list(APPEND GLOBAL_FILES
+    infcore.c
+    infget.c
+    infput.c)
 
 if(CMAKE_CROSSCOMPILING)
-    file(GLOB_RECURSE SOURCE "infros*.c")
+    list(APPEND SOURCE
+        infrosgen.c
+        infrosget.c
+        infrosput.c)
+
     add_library(inflib ${GLOBAL_FILES} ${SOURCE})
+    add_pch(inflib inflib.h)
     add_dependencies(inflib psdk)
 else()
-    file(GLOB_RECURSE SOURCE "infhost*.c")
+    list(APPEND SOURCE
+        infhostgen.c
+        infhostget.c
+        infhostput.c
+        infhostrtl.c)
+
     add_definitions(-D__NO_CTYPE_INLINES -DINFLIB_HOST)
+    add_library(inflibhost ${GLOBAL_FILES} ${SOURCE})
     if(NOT MSVC)
-        add_definitions(-Wpointer-arith -Wconversion -Wstrict-prototypes -Wmissing-prototypes)
+        add_target_compile_flags(inflibhost "-Wpointer-arith -Wwrite-strings")
     endif()
-    add_library(inflibhost ${GLOBAL_FILES} ${SOURCE})
+    target_link_libraries(inflibhost unicode)
 endif()