[MMDEVAPI_WINETEST] Sync with Wine Staging 4.0. CORE-15682
[reactos.git] / modules / CMakeLists.txt
index e09868d..4c68bfb 100644 (file)
@@ -1,12 +1,12 @@
 
-if(ENABLE_ROSTESTS)
-    add_subdirectory(rostests)
-endif()
-
 if(ENABLE_ROSAPPS)
     add_subdirectory(rosapps)
 endif()
 
+if(ENABLE_ROSTESTS)
+    add_subdirectory(rostests)
+endif()
+
 if(ENABLE_WALLPAPERS)
     add_subdirectory(wallpapers)
 endif()
@@ -17,6 +17,8 @@ endif()
 
 ## Extra files for Boot/Live/Hybrid CD. You need to put them under [boot|live|hybrid]cd_extras
 ## in the same layout as you want them to be in the CD.
+## If you change the content of any of the following folders later on,
+## run "cmake ." before compiling.
 if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/bootcd_extras/)
     file(GLOB_RECURSE EXTRA_FILES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/bootcd_extras/ ${CMAKE_CURRENT_SOURCE_DIR}/bootcd_extras/*)
     foreach(item ${EXTRA_FILES})
@@ -35,3 +37,11 @@ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/hybridcd_extras/)
         add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/hybridcd_extras/${item} DESTINATION extras NO_CAB NAME_ON_CD ${item} FOR hybridcd)
     endforeach(item)
 endif()
+
+## Extra files which you need existing on the hard drive after the installation.
+if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/)
+    file(GLOB_RECURSE EXTRA_FILES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/ ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/*)
+    foreach(item ${EXTRA_FILES})
+        add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/${item} DESTINATION reactos/3rdParty NAME_ON_CD ${item} FOR bootcd)
+    endforeach(item)
+endif()