[CMAKE] Replace custom functions to built-in ones
[reactos.git] / modules / rosapps / templates / dialog / CMakeLists.txt
index 6102bb4..16aed4a 100644 (file)
@@ -10,7 +10,7 @@ list(APPEND SOURCE
 add_executable(template_dialog ${SOURCE} dialog.rc)
 set_module_type(template_dialog win32cui)
 if(NOT MSVC)
-    add_target_compile_flags(template_dialog "-Wno-unused-but-set-variable")
+    target_compile_options(template_dialog PRIVATE "-Wno-unused-but-set-variable")
 endif()
 add_importlibs(template_dialog user32 gdi32 comctl32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET template_dialog DESTINATION reactos/system32 FOR all)