[CMAKE] Get rid of the set_cpp macro
[reactos.git] / modules / rostests / apitests / atl / CMakeLists.txt
index c0c3781..11ca2fd 100644 (file)
@@ -1,6 +1,5 @@
 
 add_definitions(-DINITGUID -DWINETEST_USE_DBGSTR_LONGLONG)
-set_cpp(WITH_RUNTIME WITH_EXCEPTIONS)
 
 include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
@@ -29,7 +28,8 @@ add_executable(atl_apitest
     ${PCH_SKIP_SOURCE}
     atl_apitest.rc)
 
-target_link_libraries(atl_apitest wine uuid)
+target_link_libraries(atl_apitest wine uuid cpprt)
+set_target_cpp_properties(atl_apitest WITH_EXCEPTIONS)
 set_module_type(atl_apitest win32cui)
 add_importlibs(atl_apitest rpcrt4 ole32 oleaut32 msimg32 gdi32 advapi32 user32 msvcrt kernel32 ntdll)
 add_pch(atl_apitest precomp.h "${PCH_SKIP_SOURCE}")