[CMAKE] Get rid of the set_cpp macro
[reactos.git] / modules / rostests / apitests / browseui / CMakeLists.txt
index 053ca97..2ae9cc3 100644 (file)
@@ -1,12 +1,11 @@
 
-set_cpp(WITH_RTTI WITH_RUNTIME WITH_EXCEPTIONS)
 if(NOT MSVC)
     # HACK: this should be enabled globally!
     add_compile_flags_language("-std=c++11" "CXX")
 endif()
 
 include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/lib/atl 
+    ${REACTOS_SOURCE_DIR}/sdk/lib/atl
     includes)
 
 list(APPEND SOURCE
@@ -17,7 +16,9 @@ list(APPEND SOURCE
     testlist.c)
 
 add_executable(browseui_apitest ${SOURCE})
-target_link_libraries(browseui_apitest uuid wine)
+target_link_libraries(browseui_apitest uuid wine cpprt)
+
+set_target_cpp_properties(browseui_apitest WITH_EXCEPTIONS WITH_RTTI)
 set_module_type(browseui_apitest win32cui)
 add_importlibs(browseui_apitest advapi32 shell32 ole32 shlwapi msvcrt kernel32 ntdll)
 add_rostests_file(TARGET browseui_apitest)