[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / modules / rostests / apitests / com / CMakeLists.txt
index 73f0000..865e71c 100644 (file)
@@ -3,19 +3,24 @@ add_definitions(-DWINE_NO_UNICODE_MACROS)
 
 list(APPEND SOURCE
     browseui.c
+    com_apitest.c
     ieframe.c
     netcfgx.c
     netshell.c
     ole32.c
     shdocvw.c
     shell32.c
-    zipfldr.c
-    com_apitest.c
-    com_apitest.h)
+    zipfldr.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    testlist.c)
+
+add_executable(com_apitest
+    ${SOURCE}
+    ${PCH_SKIP_SOURCE})
 
-add_executable(com_apitest ${SOURCE} testlist.c)
 target_link_libraries(com_apitest wine uuid)
 set_module_type(com_apitest win32cui)
 add_importlibs(com_apitest advapi32 ole32 shlwapi shell32 msvcrt kernel32 ntdll)
-add_pch(com_apitest com_apitest.h SOURCE)
+add_pch(com_apitest com_apitest.h "${PCH_SKIP_SOURCE}")
 add_rostests_file(TARGET com_apitest)