[LOCALSPL] Fix parameter handling in LocalSetJob and add tests for the few ways we...
[reactos.git] / modules / rostests / apitests / localspl / dll / CMakeLists.txt
index 2ce4287..4c518ee 100644 (file)
@@ -4,11 +4,12 @@ include_directories(${REACTOS_SOURCE_DIR}/win32ss/printing/include)
 list(APPEND SOURCE
     fpEnumPrinters.c
     fpGetPrintProcessorDirectory.c
+    fpSetJob.c
     main.c)
 
 add_library(localspl_apitest.dll SHARED ${SOURCE})
 target_link_libraries(localspl_apitest.dll wine ${PSEH_LIB})
 set_module_type(localspl_apitest.dll win32dll)
-add_importlibs(localspl_apitest.dll spoolss msvcrt kernel32 ntdll)
+add_importlibs(localspl_apitest.dll spoolss advapi32 msvcrt kernel32 ntdll)
 set_target_properties(localspl_apitest.dll PROPERTIES SUFFIX "")
 add_rostests_file(TARGET localspl_apitest.dll)