[SHELL32_APITEST] Show that SHCreateDataObject behaves exactly like CIDLData_CreateFr...
[reactos.git] / modules / rostests / apitests / shell32 / CMakeLists.txt
index 48c4182..02b2862 100644 (file)
@@ -1,27 +1,43 @@
 
-spec2def(shell32_apitest.exe shell32_apitest.spec)
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
 
 set_cpp(WITH_RUNTIME)
 
+spec2def(shell32_apitest.exe shell32_apitest.spec)
+
 include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
-add_executable(shell32_apitest
-    AddCommas.c
-    Control_RunDLLW.cpp
+list(APPEND SOURCE
+    AddCommas.cpp
     CFSFolder.cpp
+    CIDLData.cpp
     CMyComputer.cpp
     CShellDesktop.cpp
     CShellLink.cpp
-    menu.cpp
+    CUserNotification.cpp
+    Control_RunDLLW.cpp
+    IShellFolderViewCB.cpp
+    OpenAs_RunDLL.cpp
     PathResolve.cpp
+    SHCreateDataObject.cpp
     SHCreateFileExtractIconW.cpp
+    SHParseDisplayName.cpp
+    ShellExecCmdLine.cpp
     ShellExecuteEx.cpp
+    ShellState.cpp
+    menu.cpp
     shelltest.cpp
-    SHParseDisplayName.cpp
+    shelltest.h)
+
+add_executable(shell32_apitest
+    ${SOURCE}
     testlist.c
     resource.rc
     ${CMAKE_CURRENT_BINARY_DIR}/shell32_apitest.def)
+
 target_link_libraries(shell32_apitest wine uuid ${PSEH_LIB})
 set_module_type(shell32_apitest win32cui)
 add_importlibs(shell32_apitest user32 gdi32 shell32 ole32 oleaut32 advapi32 shlwapi msvcrt kernel32 ntdll)
+add_pch(shell32_apitest shelltest.h SOURCE)
 add_rostests_file(TARGET shell32_apitest)