[SHELL32_APITEST] Show that SHCreateDataObject behaves exactly like CIDLData_CreateFr...
[reactos.git] / modules / rostests / apitests / shell32 / CMakeLists.txt
index 545d2cc..02b2862 100644 (file)
@@ -1,4 +1,7 @@
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 set_cpp(WITH_RUNTIME)
 
 spec2def(shell32_apitest.exe shell32_apitest.spec)
@@ -8,6 +11,7 @@ include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 list(APPEND SOURCE
     AddCommas.cpp
     CFSFolder.cpp
+    CIDLData.cpp
     CMyComputer.cpp
     CShellDesktop.cpp
     CShellLink.cpp
@@ -16,8 +20,10 @@ list(APPEND SOURCE
     IShellFolderViewCB.cpp
     OpenAs_RunDLL.cpp
     PathResolve.cpp
+    SHCreateDataObject.cpp
     SHCreateFileExtractIconW.cpp
     SHParseDisplayName.cpp
+    ShellExecCmdLine.cpp
     ShellExecuteEx.cpp
     ShellState.cpp
     menu.cpp