[SHELL32_APITEST] Disable exceptions in atl when compiling without exceptions
[reactos.git] / modules / rostests / apitests / shell32 / CMakeLists.txt
index e2c5e0c..868b686 100644 (file)
@@ -1,4 +1,7 @@
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 set_cpp(WITH_RUNTIME)
 
 spec2def(shell32_apitest.exe shell32_apitest.spec)
@@ -7,18 +10,22 @@ include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
 list(APPEND SOURCE
     AddCommas.cpp
-    Control_RunDLLW.cpp
     CFSFolder.cpp
     CMyComputer.cpp
     CShellDesktop.cpp
     CShellLink.cpp
     CUserNotification.cpp
-    menu.cpp
+    Control_RunDLLW.cpp
+    IShellFolderViewCB.cpp
+    OpenAs_RunDLL.cpp
     PathResolve.cpp
     SHCreateFileExtractIconW.cpp
+    SHParseDisplayName.cpp
+    ShellExecCmdLine.cpp
     ShellExecuteEx.cpp
+    ShellState.cpp
+    menu.cpp
     shelltest.cpp
-    SHParseDisplayName.cpp
     shelltest.h)
 
 add_executable(shell32_apitest