[SHELL32_APITEST] Add Regression Test for ShellExecuteW(). (#2166)
[reactos.git] / modules / rostests / apitests / shell32 / CMakeLists.txt
index ba7096b..e467b5c 100644 (file)
@@ -1,4 +1,7 @@
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 set_cpp(WITH_RUNTIME)
 
 spec2def(shell32_apitest.exe shell32_apitest.spec)
@@ -7,20 +10,28 @@ include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
 list(APPEND SOURCE
     AddCommas.cpp
-    Control_RunDLLW.cpp
     CFSFolder.cpp
+    CIDLData.cpp
     CMyComputer.cpp
     CShellDesktop.cpp
     CShellLink.cpp
     CUserNotification.cpp
+    Control_RunDLLW.cpp
+    DragDrop.cpp
+    ExtractIconEx.cpp
     IShellFolderViewCB.cpp
-    menu.cpp
     OpenAs_RunDLL.cpp
     PathResolve.cpp
+    SHCreateDataObject.cpp
     SHCreateFileExtractIconW.cpp
+    SHParseDisplayName.cpp
+    ShellExecCmdLine.cpp
     ShellExecuteEx.cpp
+    ShellExecuteW.cpp
+    ShellState.cpp
+    SHLimitInputEdit.cpp
+    menu.cpp
     shelltest.cpp
-    SHParseDisplayName.cpp
     shelltest.h)
 
 add_executable(shell32_apitest