Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / modules / rostests / winetests / ntdll / CMakeLists.txt
diff --git a/modules/rostests/winetests/ntdll/CMakeLists.txt b/modules/rostests/winetests/ntdll/CMakeLists.txt
new file mode 100644 (file)
index 0000000..4fe5a26
--- /dev/null
@@ -0,0 +1,41 @@
+
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
+remove_definitions(-DWINVER=0x502 -D_WIN32_IE=0x600 -D_WIN32_WINNT=0x502)
+add_definitions(-D__WINESRC__)
+
+list(APPEND SOURCE
+    atom.c
+    change.c
+    directory.c
+    env.c
+    error.c
+    exception.c
+    file.c
+    info.c
+    large_int.c
+    om.c
+    path.c
+    pipe.c
+    port.c
+    reg.c
+    rtl.c
+    rtlbitmap.c
+    rtlstr.c
+    string.c
+    time.c
+    testlist.c)
+
+if(ARCH STREQUAL "i386")
+    list(APPEND SOURCE
+    generated.c
+    )
+endif()
+
+add_executable(ntdll_winetest ${SOURCE})
+set_module_type(ntdll_winetest win32cui)
+add_importlibs(ntdll_winetest user32 ole32 advapi32 msvcrt kernel32 ntdll)
+add_rostests_file(TARGET ntdll_winetest)
+
+if(NOT MSVC)
+    add_target_compile_flags(ntdll_winetest "-Wno-format")
+endif()