[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / modules / rostests / winetests / ole32 / CMakeLists.txt
index 0cb4ec3..0b54eae 100644 (file)
@@ -15,10 +15,15 @@ list(APPEND SOURCE
     propvariant.c
     stg_prop.c
     storage32.c
-    usrmarshal.c
-    precomp.h)
+    usrmarshal.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    testlist.c)
+
+add_executable(ole32_winetest
+    ${SOURCE}
+    ${PCH_SKIP_SOURCE})
 
-add_executable(ole32_winetest ${SOURCE} testlist.c)
 target_link_libraries(ole32_winetest uuid)
 set_module_type(ole32_winetest win32cui)
 add_importlibs(ole32_winetest oleaut32 ole32 user32 gdi32 advapi32 msvcrt kernel32)
@@ -27,5 +32,5 @@ if(MSVC)
     add_importlibs(ole32_winetest ntdll)
 endif()
 
-add_pch(ole32_winetest precomp.h SOURCE)
+add_pch(ole32_winetest precomp.h "${PCH_SKIP_SOURCE}")
 add_rostests_file(TARGET ole32_winetest)