[OLEAUT32_WINETEST] Add a PCH.
[reactos.git] / modules / rostests / winetests / oleaut32 / CMakeLists.txt
index e1d61fe..bd9c0f4 100644 (file)
@@ -10,7 +10,6 @@ list(APPEND SOURCE
     olefont.c
     olepicture.c
     safearray.c
-    testlist.c
     tmarshal.c
     typelib.c
     usrmarshal.c
@@ -19,7 +18,8 @@ list(APPEND SOURCE
     vartype.c
     ${CMAKE_CURRENT_BINARY_DIR}/test_reg_i.c
     ${CMAKE_CURRENT_BINARY_DIR}/test_tlb_i.c
-    ${CMAKE_CURRENT_BINARY_DIR}/tmarshal_i.c)
+    ${CMAKE_CURRENT_BINARY_DIR}/tmarshal_i.c
+    precomp.h)
 
 set(tmarshal.rc_DEPS
     ${CMAKE_CURRENT_BINARY_DIR}/test_reg.tlb
@@ -27,7 +27,7 @@ set(tmarshal.rc_DEPS
     ${CMAKE_CURRENT_BINARY_DIR}/tmarshal.tlb)
 
 set_source_files_properties(tmarshal.rc PROPERTIES OBJECT_DEPENDS "${tmarshal.rc_DEPS}")
-add_executable(oleaut32_winetest ${SOURCE} tmarshal.rc)
+add_executable(oleaut32_winetest ${SOURCE} testlist.c tmarshal.rc)
 target_link_libraries(oleaut32_winetest uuid)
 set_module_type(oleaut32_winetest win32cui)
 add_importlibs(oleaut32_winetest oleaut32 ole32 rpcrt4 user32 gdi32 advapi32 msvcrt kernel32)
@@ -37,4 +37,5 @@ if(MSVC)
 endif()
 
 add_dependencies(oleaut32_winetest stdole2 oleaut32_idlheaders)
+add_pch(oleaut32_winetest precomp.h SOURCE)
 add_rostests_file(TARGET oleaut32_winetest)