[CMAKE]
[reactos.git] / ntoskrnl / CMakeLists.txt
index f10b62c..43046bb 100644 (file)
@@ -32,7 +32,6 @@ if(NEWCC)
         cache/pinsup.c
         cache/section/data.c
         cache/section/fault.c
-        cache/section/io.c
         cache/section/reqtools.c
         cache/section/sptab.c
         cache/section/swapout.c)
@@ -47,6 +46,7 @@ else()
 endif()
 
 list(APPEND SOURCE
+    cache/section/io.c
     config/cmalloc.c
     config/cmapi.c
     config/cmboot.c
@@ -446,10 +446,9 @@ target_link_libraries(ntoskrnl
 add_importlibs(ntoskrnl hal kdcom bootvid)
 
 add_pch(ntoskrnl ${CMAKE_CURRENT_SOURCE_DIR}/include/ntoskrnl.h ${SOURCE})
-add_dependencies(ntoskrnl psdk bugcodes kernel_zw kernel_napi asm)
+add_dependencies(ntoskrnl psdk bugcodes asm)
 
-add_minicd_target(ntoskrnl reactos ntoskrnl.exe)
-add_livecd_target(ntoskrnl reactos/system32)
+add_cd_file(TARGET ntoskrnl DESTINATION reactos/system32 NO_CAB)
 add_importlib_target(ntoskrnl.spec)
 
 add_library(ntdllsys ntdll.S)