[BTRFSLIB]
[reactos.git] / reactos / CMakeLists.txt
index dd734f8..d90eef1 100644 (file)
@@ -37,12 +37,8 @@ set(CMAKE_COLOR_MAKEFILE OFF)
 #set_property(GLOBAL PROPERTY RULE_MESSAGES OFF)
 set(CMAKE_SKIP_INSTALL_RULES ON)
 
-if(NOT CMAKE_VERSION STREQUAL "2.8.12.1-ReactOS")
-    set(CMAKE_DISABLE_NINJA_DEPSLOG TRUE)
-endif()
-
 if(NOT DEFINED NEW_STYLE_BUILD)
-    set(NEW_STYLE_BUILD FALSE)
+    set(NEW_STYLE_BUILD TRUE)
 endif()
 
 if(NOT ARCH)
@@ -112,9 +108,9 @@ if(NOT CMAKE_CROSSCOMPILING)
 
     if(NOT NEW_STYLE_BUILD)
         if(NOT MSVC)
-            export(TARGETS bin2c widl gendib cabman cdmake hpp mkhive obj2bin spec2def geninc rsym mkshelllink utf16le FILE ${CMAKE_BINARY_DIR}/ImportExecutables.cmake NAMESPACE native- )
+            export(TARGETS bin2c widl gendib cabman cdmake fatten hpp mkhive obj2bin spec2def geninc rsym mkshelllink utf16le FILE ${CMAKE_BINARY_DIR}/ImportExecutables.cmake NAMESPACE native- )
         else()
-            export(TARGETS bin2c widl gendib cabman cdmake hpp mkhive obj2bin spec2def geninc mkshelllink utf16le FILE ${CMAKE_BINARY_DIR}/ImportExecutables.cmake NAMESPACE native- )
+            export(TARGETS bin2c widl gendib cabman cdmake fatten hpp mkhive obj2bin spec2def geninc mkshelllink utf16le FILE ${CMAKE_BINARY_DIR}/ImportExecutables.cmake NAMESPACE native- )
         endif()
     endif()
 
@@ -124,6 +120,9 @@ else()
         include(cmake/host-tools.cmake)
     endif()
 
+    # Print build type
+    message("-- Build Type: ${CMAKE_BUILD_TYPE}")
+
     # adjust the default behaviour of the FIND_XXX() commands:
     # search headers and libraries in the target environment, search
     # programs in the host environment