[CALC] Explicitly link against comctl32. Patch by Carlo Bramini. CORE-10727
[reactos.git] / reactos / base / applications / calc / CMakeLists.txt
index 85332bd..2d0d605 100644 (file)
@@ -2,7 +2,6 @@
 add_definitions(-DDISABLE_HTMLHELP_SUPPORT=1)
 
 list(APPEND SOURCE
-    about.c
     convert.c
     function.c
     rpn.c
@@ -10,13 +9,13 @@ list(APPEND SOURCE
     winmain.c
     calc.h)
 
+file(GLOB calc_rc_deps res/*.*)
+add_rc_deps(resource.rc ${calc_rc_deps})
 add_executable(calc ${SOURCE} resource.rc)
 set_module_type(calc win32gui UNICODE)
-add_importlibs(calc advapi32 user32 gdi32 msvcrt kernel32)
+add_importlibs(calc advapi32 comctl32 user32 shell32 gdi32 msvcrt kernel32)
 
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
-    target_link_libraries(calc mingwex)
-elseif(MSVC)
+if(MSVC)
     add_importlibs(calc ntdll)
 endif()