[CALC] Explicitly link against comctl32. Patch by Carlo Bramini. CORE-10727
[reactos.git] / reactos / base / applications / calc / CMakeLists.txt
index 870e6f1..2d0d605 100644 (file)
@@ -2,7 +2,6 @@
 add_definitions(-DDISABLE_HTMLHELP_SUPPORT=1)
 
 list(APPEND SOURCE
-    about.c
     convert.c
     function.c
     rpn.c
@@ -10,11 +9,15 @@ list(APPEND SOURCE
     winmain.c
     calc.h)
 
+file(GLOB calc_rc_deps res/*.*)
+add_rc_deps(resource.rc ${calc_rc_deps})
 add_executable(calc ${SOURCE} resource.rc)
 set_module_type(calc win32gui UNICODE)
-add_importlibs(calc advapi32 user32 gdi32 msvcrt kernel32)
+add_importlibs(calc advapi32 comctl32 user32 shell32 gdi32 msvcrt kernel32)
+
 if(MSVC)
     add_importlibs(calc ntdll)
 endif()
+
 add_pch(calc calc.h SOURCE)
 add_cd_file(TARGET calc DESTINATION reactos/system32 FOR all)