[MSCONFIG_NEW]
[reactos.git] / reactos / base / applications / msconfig_new / CMakeLists.txt
index 44a5812..6a11f88 100644 (file)
@@ -1,12 +1,13 @@
 
 PROJECT(msconfig_new)
 
-set_cpp(WITH_RUNTIME)
+set_cpp(WITH_RUNTIME WITH_EXCEPTIONS)
 
 include_directories(
     .
     comctl32ex
-    ${REACTOS_SOURCE_DIR}/include/c++)
+    ${REACTOS_SOURCE_DIR}/include/c++
+    ${REACTOS_SOURCE_DIR}/lib/atl)
 
 list(APPEND C_SOURCE
     comctl32ex/listviewfuncs.c
@@ -15,13 +16,14 @@ list(APPEND C_SOURCE
     freeldrpage.c
     generalpage.c
     msconfig.c
-    # srvpage.c
+    regutils.c
     # systempage.c
     # startuppage.c
     stringutils.c
     utils.c)
 
 list(APPEND CPP_SOURCE
+    srvpage.cpp
     toolspage.cpp
     xmldomparser.cpp
     precomp.h)
@@ -30,6 +32,6 @@ add_rc_deps(msconfig.rc ${CMAKE_CURRENT_SOURCE_DIR}/res/msconfig.ico)
 add_executable(msconfig_new ${C_SOURCE} ${CPP_SOURCE} msconfig.rc)
 add_pch(msconfig_new precomp.h CPP_SOURCE)
 set_module_type(msconfig_new win32gui UNICODE)
-target_link_libraries(msconfig_new comsupp)
+target_link_libraries(msconfig_new atlnew comsupp)
 add_importlibs(msconfig_new user32 gdi32 comctl32 comdlg32 advapi32 version ole32 oleaut32 msxml3 shell32 shlwapi msvcrt kernel32)
 add_cd_file(TARGET msconfig_new DESTINATION reactos/system32 FOR all)