[SERVMAN]
[reactos.git] / reactos / base / applications / mscutils / servman / CMakeLists.txt
index cbfb698..1f96e06 100644 (file)
@@ -14,15 +14,19 @@ list(APPEND SOURCE
     propsheet.c
     propsheet_depends.c
     propsheet_general.c
+    propsheet_logon.c
+    propsheet_recovery.c
     query.c
     servman.c
     start.c
     stop.c
     stop_dependencies.c
-    servman.rc)
+    precomp.h)
 
-add_executable(servman ${SOURCE})
+file(GLOB servman_rc_deps res/*.*)
+add_rc_deps(servman.rc ${servman_rc_deps})
+add_executable(servman ${SOURCE} servman.rc)
 set_module_type(servman win32gui UNICODE)
-add_importlibs(servman user32 gdi32 advapi32 version comctl32 shell32 comdlg32 msvcrt kernel32)
-add_pch(servman precomp.h)
+add_importlibs(servman user32 gdi32 advapi32 version comctl32 shell32 comdlg32 msvcrt kernel32 ntdll)
+add_pch(servman precomp.h SOURCE)
 add_cd_file(TARGET servman DESTINATION reactos/system32 FOR all)