[APPLICATIONS] Properly track resource file dependencies. CORE-9806
[reactos.git] / reactos / base / applications / wordpad / CMakeLists.txt
index 4a1c36e..9a6848c 100644 (file)
@@ -8,10 +8,11 @@ list(APPEND SOURCE
     olecallback.c
     print.c
     registry.c
-    wordpad.c
-    rsrc.rc)
+    wordpad.c)
 
-add_executable(wordpad ${SOURCE})
+file(GLOB wordpad_rc_deps res/*.*)
+add_rc_deps(rsrc.rc ${wordpad_rc_deps})
+add_executable(wordpad ${SOURCE} rsrc.rc)
 set_module_type(wordpad win32gui)
 target_link_libraries(wordpad wine uuid)
 add_importlibs(wordpad comdlg32 ole32 shell32 user32 gdi32 advapi32 comctl32 msvcrt kernel32 ntdll)