[CMAKE/RPC]
[reactos.git] / reactos / base / services / eventlog / CMakeLists.txt
index 221bc9f..50f0574 100644 (file)
@@ -1,20 +1,23 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/idl
+include_directories(
+    ${REACTOS_SOURCE_DIR}/include/reactos/idl
     ${CMAKE_CURRENT_BINARY_DIR})
 
-add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/eventlogrpc.idl)
+# FIXME: See CORE-8200
+set(IDL_FLAGS ${IDL_FLAGS} -Oif)
 
+add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/eventlogrpc.idl)
 
 list(APPEND SOURCE
     eventlog.c
     eventsource.c
     logport.c
-    eventlog.rc
     rpc.c
     file.c
+    eventlog.h
     ${CMAKE_CURRENT_BINARY_DIR}/eventlogrpc_s.c)
 
-add_executable(eventlog ${SOURCE})
+add_executable(eventlog ${SOURCE} eventlog.rc)
 
 if(NOT MSVC)
     target_link_libraries(eventlog ${PSEH_LIB})
@@ -22,5 +25,5 @@ endif()
 
 set_module_type(eventlog win32cui UNICODE)
 add_importlibs(eventlog advapi32 rpcrt4 msvcrt kernel32 ntdll)
-add_pch(eventlog eventlog.h)
+add_pch(eventlog eventlog.h SOURCE)
 add_cd_file(TARGET eventlog DESTINATION reactos/system32 FOR all)