[UMPNPMGR]
[reactos.git] / reactos / base / services / umpnpmgr / CMakeLists.txt
index 958fad2..5987acf 100644 (file)
@@ -1,21 +1,21 @@
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/idl)
 
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
-
 add_rpc_files(server ${REACTOS_SOURCE_DIR}/include/reactos/idl/pnp.idl)
 
+spec2def(umpnpmgr.dll umpnpmgr.spec ADD_IMPORTLIB)
 
-add_executable(umpnpmgr
+add_library(umpnpmgr SHARED
     umpnpmgr.c
     umpnpmgr.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/pnp_s.c)
+    ${CMAKE_CURRENT_BINARY_DIR}/pnp_s.c
+    ${CMAKE_CURRENT_BINARY_DIR}/umpnpmgr_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/umpnpmgr.def)
 
 target_link_libraries(umpnpmgr
     wdmguid
     ${PSEH_LIB})
 
-set_module_type(umpnpmgr win32cui UNICODE)
-add_importlibs(umpnpmgr advapi32 rpcrt4 userenv msvcrt kernel32 ntdll)
+set_module_type(umpnpmgr win32dll UNICODE)
+add_importlibs(umpnpmgr advapi32 rpcrt4 userenv shlwapi msvcrt kernel32 ntdll)
 add_cd_file(TARGET umpnpmgr DESTINATION reactos/system32 FOR all)