Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / reactos / base / shell / rshell / CMakeLists.txt
diff --git a/reactos/base/shell/rshell/CMakeLists.txt b/reactos/base/shell/rshell/CMakeLists.txt
deleted file mode 100644 (file)
index 3d70d6b..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-PROJECT(SHELL)
-
-set_cpp(WITH_RUNTIME)
-
-include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/lib/atl)
-
-spec2def(rshell.dll rshell.spec ADD_IMPORTLIB)
-
-list(APPEND SOURCE
-    misc.cpp
-    ${CMAKE_CURRENT_BINARY_DIR}/rshell.def)
-
-add_library(rshell SHARED ${SOURCE})
-
-set_module_type(rshell win32dll UNICODE)
-
-target_link_libraries(rshell
-    shellbars
-    shellmenu
-    shelldesktop
-    atlnew
-    uuid
-    wine)
-
-add_importlibs(rshell
-    browseui
-    uxtheme
-    shlwapi
-    advapi32
-    shell32
-    comctl32
-    gdi32
-    ole32
-    user32
-    msvcrt
-    kernel32
-    ntdll)
-
-add_custom_command(TARGET rshell POST_BUILD 
-  COMMAND "${CMAKE_COMMAND}" -E copy 
-     "$<TARGET_FILE:rshell>"
-     "$<TARGET_FILE_DIR:explorer>/$<TARGET_FILE_NAME:rshell>" 
-  COMMENT "Copying to output directory")
-
-add_custom_command(TARGET rshell POST_BUILD 
-  COMMAND "${CMAKE_COMMAND}" -E copy 
-     "$<TARGET_FILE:rshell>"
-     "$<TARGET_FILE_DIR:filebrowser>/$<TARGET_FILE_NAME:rshell>" 
-  COMMENT "Copying to output directory")
-
-add_custom_command(TARGET rshell POST_BUILD 
-  COMMAND "${CMAKE_COMMAND}" -E copy 
-     "$<TARGET_FILE:rshell>"
-     "$<TARGET_FILE_DIR:filebrowser>/$<TARGET_FILE_NAME:rshell>" 
-  COMMENT "Copying to output directory")