[D3DRM] Sync with Wine Staging 1.7.55. CORE-10536
[reactos.git] / reactos / dll / directx / wine / d3drm / CMakeLists.txt
index bc3bc9f..8ba7988 100644 (file)
@@ -1,7 +1,7 @@
 
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-spec2def(d3drm.dll d3drm.spec)
+spec2def(d3drm.dll d3drm.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     d3drm.c
@@ -30,6 +30,6 @@ if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
     target_link_libraries(d3drm mingwex)
 endif()
 
-add_importlibs(d3drm d3dxof msvcrt kernel32 ntdll)
+add_importlibs(d3drm ddraw d3dxof msvcrt kernel32 ntdll)
 add_pch(d3drm d3drm_private.h SOURCE)
 add_cd_file(TARGET d3drm DESTINATION reactos/system32 FOR all)