[MSGINA]
[reactos.git] / reactos / dll / ntdll / CMakeLists.txt
index 1a90479..9e51fc2 100644 (file)
@@ -26,18 +26,23 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
 
 if(ARCH STREQUAL "i386")
-    list(APPEND SOURCE dispatch/i386/dispatch.S)
+    list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
 elseif(ARCH STREQUAL "amd64")
-    list(APPEND SOURCE dispatch/amd64/dispatch.S)
+    list(APPEND ASM_SOURCE dispatch/amd64/dispatch.S)
 elseif(ARCH STREQUAL "arm")
-    list(APPEND SOURCE dispatch/arm/stubs_asm.s)
+    list(APPEND ASM_SOURCE dispatch/arm/stubs_asm.s)
 else()
     list(APPEND SOURCE dispatch/dispatch.c)
-endif(ARCH STREQUAL "i386")
+endif()
 
-add_library(ntdll SHARED ${SOURCE})
+add_asm_files(ntdll_asm ${ASM_SOURCE})
+add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
 
 set_module_type(ntdll win32dll ENTRYPOINT 0)
+#############################################
+## HACK FOR MSVC COMPILATION WITH win32dll ##
+set_subsystem(ntdll console)
+################# END  HACK #################
 
 if(MSVC)
     add_target_link_flags(ntdll "/RELEASE")
@@ -47,6 +52,7 @@ target_link_libraries(ntdll
                       rtl
                       ntdllsys
                       libcntpr
+                      uuid
                       ${PSEH_LIB})
 
 add_pch(ntdll include/ntdll.h)