[AVIFIL32]
[reactos.git] / reactos / dll / ntdll / CMakeLists.txt
index 5e1c751..9e51fc2 100644 (file)
@@ -1,5 +1,5 @@
 
-spec2def(ntdll.dll def/ntdll.spec)
+spec2def(ntdll.dll def/ntdll.spec ADD_IMPORTLIB)
 
 add_definitions(
     -D__NTDLL__
@@ -8,7 +8,8 @@ add_definitions(
 
 include_directories(
     BEFORE include
-    ${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys
+    ${REACTOS_SOURCE_DIR}/win32ss/include)
 
 list(APPEND SOURCE
     csr/api.c
@@ -24,33 +25,38 @@ list(APPEND SOURCE
     def/ntdll.rc
     ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
 
-if(ARCH MATCHES i386)
-    list(APPEND SOURCE dispatch/i386/dispatch.S)
-elseif(ARCH MATCHES amd64)
-    list(APPEND SOURCE dispatch/amd64/stubs.c)
-elseif(ARCH MATCHES arm)
-    list(APPEND SOURCE dispatch/arm/stubs_asm.s)
+if(ARCH STREQUAL "i386")
+    list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
+elseif(ARCH STREQUAL "amd64")
+    list(APPEND ASM_SOURCE dispatch/amd64/dispatch.S)
+elseif(ARCH STREQUAL "arm")
+    list(APPEND ASM_SOURCE dispatch/arm/stubs_asm.s)
 else()
     list(APPEND SOURCE dispatch/dispatch.c)
-endif(ARCH MATCHES i386)
+endif()
 
-add_library(ntdll SHARED ${SOURCE})
+add_asm_files(ntdll_asm ${ASM_SOURCE})
+add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
 
-set_entrypoint(ntdll 0)
+set_module_type(ntdll win32dll ENTRYPOINT 0)
+#############################################
+## HACK FOR MSVC COMPILATION WITH win32dll ##
+set_subsystem(ntdll console)
+################# END  HACK #################
 
 if(MSVC)
-    add_linkerflag(ntdll /RELEASE)
+    add_target_link_flags(ntdll "/RELEASE")
 endif()
 
 target_link_libraries(ntdll
                       rtl
                       ntdllsys
                       libcntpr
+                      uuid
                       ${PSEH_LIB})
 
-set_image_base(ntdll ${baseaddress_ntdll})
 add_pch(ntdll include/ntdll.h)
 add_dependencies(ntdll ntstatus asm)
 
 add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB FOR all)
-add_importlib_target(def/ntdll.spec)
+