[AVIFIL32]
[reactos.git] / reactos / dll / ntdll / CMakeLists.txt
index 7ad8547..9e51fc2 100644 (file)
@@ -39,6 +39,10 @@ add_asm_files(ntdll_asm ${ASM_SOURCE})
 add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
 
 set_module_type(ntdll win32dll ENTRYPOINT 0)
+#############################################
+## HACK FOR MSVC COMPILATION WITH win32dll ##
+set_subsystem(ntdll console)
+################# END  HACK #################
 
 if(MSVC)
     add_target_link_flags(ntdll "/RELEASE")
@@ -48,6 +52,7 @@ target_link_libraries(ntdll
                       rtl
                       ntdllsys
                       libcntpr
+                      uuid
                       ${PSEH_LIB})
 
 add_pch(ntdll include/ntdll.h)