[FMIFS]
[reactos.git] / reactos / dll / ntdll / CMakeLists.txt
index 83e9999..d990093 100644 (file)
@@ -22,8 +22,7 @@ list(APPEND SOURCE
     ldr/ldrutils.c
     rtl/libsupp.c
     rtl/version.c
-    def/ntdll.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+    include/ntdll.h)
 
 if(ARCH STREQUAL "i386")
     list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
@@ -36,9 +35,15 @@ else()
 endif()
 
 add_asm_files(ntdll_asm ${ASM_SOURCE})
-add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
 
-set_module_type(ntdll win32dll ENTRYPOINT 0)
+add_library(ntdll SHARED
+    ${SOURCE}
+    ${ntdll_asm}
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+
+set_module_type(ntdll win32dll HOTPATCHABLE ENTRYPOINT 0)
 #############################################
 ## HACK FOR MSVC COMPILATION WITH win32dll ##
 set_subsystem(ntdll console)
@@ -52,9 +57,10 @@ target_link_libraries(ntdll
                       rtl
                       ntdllsys
                       libcntpr
+                      uuid
                       ${PSEH_LIB})
 
-add_pch(ntdll include/ntdll.h)
+add_pch(ntdll include/ntdll.h SOURCE)
 add_dependencies(ntdll ntstatus asm)
 
 add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB FOR all)