[CMAKE]
[reactos.git] / reactos / dll / opengl / mesa / main / CMakeLists.txt
index c61aebb..b4e4a96 100644 (file)
@@ -6,15 +6,12 @@ list(APPEND SOURCE
     api_validate.c
     accum.c
     attrib.c
-    arrayobj.c
     blend.c
     bufferobj.c
     buffers.c
     clear.c
     clip.c
-    colortab.c
     context.c
-    convolve.c
     cpuinfo.c
     depth.c
     dlist.c
@@ -35,7 +32,6 @@ list(APPEND SOURCE
     getstring.c
     hash.c
     hint.c
-    histogram.c
     image.c
     imports.c
     light.c
@@ -44,7 +40,6 @@ list(APPEND SOURCE
     mm.c
     multisample.c
     pack.c
-    pbo.c
     pixel.c
     pixelstore.c
     pixeltransfer.c
@@ -63,16 +58,20 @@ list(APPEND SOURCE
     texgetimage.c
     teximage.c
     texobj.c
-    texpal.c
+    #texpal.c
     texparam.c
     texstate.c
     texstorage.c
     texstore.c
-    texturebarrier.c
     varray.c
     version.c
     viewport.c
     vtxfmt.c
-)
+    precomp.h)
 
-add_library(mesa_main STATIC ${SOURCE})
\ No newline at end of file
+add_library(mesa_main STATIC ${SOURCE})
+add_pch(mesa_main precomp.h SOURCE)
+
+if(NOT MSVC)
+    add_target_compile_flags(mesa_main "-Wno-type-limits")
+endif()