[OPENGL32]
[reactos.git] / reactos / dll / opengl / opengl32 / CMakeLists.txt
index d5b4382..1d9d247 100644 (file)
@@ -1,9 +1,7 @@
 
 spec2def(opengl32.dll opengl32.spec ADD_IMPORTLIB)
 
-include_directories(
-    ../mesa/src/mesa
-    ../mesa/src/mapi)
+include_directories(../mesa)
 
 add_definitions(
     -D_GDI32_ # prevent gl* being declared __declspec(dllimport) in MS headers
@@ -11,9 +9,6 @@ add_definitions(
     -D_GLAPI_NO_EXPORTS # prevent _glapi_* from being declared __declspec(dllimport)
 )
 
-# useful to test under windows <> w2k3
-set(OPENGL32_USE_TLS TRUE)
-
 if(OPENGL32_USE_TLS)
     add_definitions(-DOPENGL32_USE_TLS)
 endif()
@@ -33,12 +28,12 @@ set_source_files_properties(gcrt0.o libgmon.a PROPERTIES EXTERNAL_OBJECT TRUE)
 
 if(ARCH STREQUAL "i386")
     # Optimisation: use asm trampolines to ICD provided functions
-    list(APPEND SOURCE
+    add_asm_files(opengl32_asm
         glapi_x86.s
     )
 endif()
 
-add_library(opengl32 SHARED ${SOURCE})
+add_library(opengl32 SHARED ${SOURCE} ${opengl32_asm})
 target_link_libraries(opengl32
     wine
     ${PSEH_LIB}
@@ -58,4 +53,4 @@ endif()
 set_module_type(opengl32 win32dll)
 
 add_importlibs(opengl32 gdi32 user32 advapi32 msvcrt kernel32 ntdll)
-add_cd_file(TARGET opengl32 DESTINATION reactos/system32 FOR all)
\ No newline at end of file
+add_cd_file(TARGET opengl32 DESTINATION reactos/system32 FOR all)