[CMAKE]
[reactos.git] / reactos / dll / shellext / devcpux / CMakeLists.txt
diff --git a/reactos/dll/shellext/devcpux/CMakeLists.txt b/reactos/dll/shellext/devcpux/CMakeLists.txt
new file mode 100644 (file)
index 0000000..6070192
--- /dev/null
@@ -0,0 +1,19 @@
+
+set_unicode()
+set_rc_compiler()
+
+spec2def(devcpux.dll devcpux.spec)
+
+add_library(devcpux SHARED processor.c processor.rc ${CMAKE_CURRENT_BINARY_DIR}/devcpux.def)
+
+set_module_type(devcpux win32dll)
+
+add_importlibs(devcpux
+    user32
+    powrprof
+    comctl32
+    msvcrt
+    kernel32
+    ntdll)
+
+add_cd_file(TARGET devcpux DESTINATION reactos/system32 FOR all)