[ACTIVEDS] Order the exports, add missing ones and make sure the list matches our...
[reactos.git] / reactos / dll / win32 / activeds / activeds.spec
index 2b79ca3..4fad6c9 100644 (file)
@@ -5,7 +5,9 @@
 7 stdcall ADsBuildVarArrayStr(ptr long ptr)
 8 stdcall ADsBuildVarArrayInt(ptr long ptr)
 9 stdcall ADsOpenObject(wstr wstr wstr long ptr ptr)
-12 stdcall ADsSetLastError(long str str)
+#@ stdcall -private DllCanUnloadNow()
+#@ stdcall -private DllGetClassObject(ptr ptr ptr)
+12 stdcall ADsSetLastError(long ptr ptr)
 13 stdcall ADsGetLastError(ptr ptr long ptr long)
 14 stdcall AllocADsMem(long)
 15 stdcall FreeADsMem(ptr)
@@ -22,7 +24,8 @@
 26 cdecl PropVariantToAdsType2() # unknown prototype
 27 cdecl ConvertSecDescriptorToVariant() # unknown prototype
 28 cdecl ConvertSecurityDescriptorToSecDes() # unknown prototype
-#@ stdcall -private DllCanUnloadNow()
-#@ stdcall -private DllGetClassObject(ptr ptr ptr)
+# BinarySDToSecurityDescriptor
+# SecurityDescriptorToBinarySD
+# ConvertTrusteeToSid
 #@ stdcall -private DllRegisterServer()
 #@ stdcall -private DllUnregisterServer()