[COMCTL32] Sync with Wine Staging 1.7.55. CORE-10536
[reactos.git] / reactos / dll / win32 / comctl32 / CMakeLists.txt
index 1b9d877..fc0527b 100644 (file)
@@ -1,6 +1,4 @@
 
-set_rc_compiler()
-
 add_definitions(
     -D__WINESRC__
     -D_WINE
@@ -10,7 +8,6 @@ remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 include_directories(BEFORE ${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 spec2def(comctl32.dll comctl32.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -44,29 +41,24 @@ list(APPEND SOURCE
     theme_dialog.c
     theme_edit.c
     theme_listbox.c
+    theme_scrollbar.c
     theming.c
     toolbar.c
     tooltips.c
     trackbar.c
     treeview.c
     updown.c
+    comctl32.h)
+
+add_library(comctl32 SHARED
+    ${SOURCE}
     stubs.c
     rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/comctl32.def)
 
-add_library(comctl32 SHARED ${SOURCE})
 set_module_type(comctl32 win32dll UNICODE)
 target_link_libraries(comctl32 uuid wine ${PSEH_LIB})
 add_delay_importlibs(comctl32 winmm uxtheme)
-
-add_importlibs(comctl32
-    user32
-    gdi32
-    advapi32
-    msvcrt
-    kernel32
-    ntdll)
-
-add_pch(comctl32 comctl32.h)
+add_importlibs(comctl32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
+add_pch(comctl32 comctl32.h SOURCE)
 add_cd_file(TARGET comctl32 DESTINATION reactos/system32 FOR all)
-