[CMAKE]
[reactos.git] / reactos / dll / win32 / crypt32 / CMakeLists.txt
index aef59eb..8728bc6 100644 (file)
@@ -1,12 +1,12 @@
 
+remove_definitions(-D_WIN32_WINNT=0x502 -DWINVER=0x502)
+add_definitions(-D_WIN32_WINNT=0x600 -DWINVER=0x600)
+
 add_definitions(
     -D__WINESRC__
     -D_WINE
     -D_CRYPT32_)
 
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(crypt32.dll crypt32.spec ADD_IMPORTLIB)
 
@@ -45,6 +45,7 @@ add_library(crypt32 SHARED
 
 set_module_type(crypt32 win32dll)
 target_link_libraries(crypt32 wine ${PSEH_LIB} oldnames)
-add_importlibs(crypt32 user32 advapi32 msvcrt kernel32 ntdll)
+add_delay_importlibs(crypt32 cryptnet)
+add_importlibs(crypt32 user32 advapi32 advapi32_vista msvcrt kernel32 ntdll)
 add_pch(crypt32 crypt32_private.h SOURCE)
 add_cd_file(TARGET crypt32 DESTINATION reactos/system32 FOR all)