[DEVMGR]
[reactos.git] / reactos / dll / win32 / devmgr_new / CMakeLists.txt
index 179e0ce..bdc3f79 100644 (file)
@@ -1,14 +1,24 @@
 
 spec2def(devmgr.dll devmgr.spec ADD_IMPORTLIB)
 
+set_cpp(WITH_RTTI WITH_STL)
+
+include_directories(${REACTOS_SOURCE_DIR}/lib/atl)
+
 list(APPEND SOURCE
-    advprop.c
-    devprblm.c
-    hwpage.c
-    hwresource.c
-    misc.c
-    stubs.c
     precomp.h
+    Properties/advprop.c
+    Properties/devprblm.c
+    Properties/hwpage.c
+    Properties/hwresource.c
+    Properties/misc.c
+    Properties/stubs.c 
+    devmgmt/ClassNode.cpp
+    devmgmt/DeviceNode.cpp
+    devmgmt/DeviceView.cpp
+    devmgmt/MainWindow.cpp
+    devmgmt/Node.cpp
+    devmgmt/RootNode.cpp
     ${CMAKE_CURRENT_BINARY_DIR}/devmgr_stubs.c)
 
 add_library(devmgr SHARED
@@ -17,7 +27,6 @@ add_library(devmgr SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/devmgr.def)
 
 set_module_type(devmgr win32dll UNICODE)
-target_link_libraries(devmgr uuid wine)
-add_importlibs(devmgr setupapi advapi32 newdev user32 version msvcrt kernel32 ntdll)
-add_pch(devmgr precomp.h SOURCE)
+target_link_libraries(devmgr uuid atlnew wine)
+add_importlibs(devmgr setupapi advapi32 newdev user32 gdi32 comctl32 version msvcrt kernel32 ole32 uxtheme ntdll)
 add_cd_file(TARGET devmgr DESTINATION reactos/system32 FOR all)