[CMAKE]
[reactos.git] / reactos / dll / win32 / hhctrl.ocx / CMakeLists.txt
index 2e967c9..8d199af 100644 (file)
@@ -30,13 +30,9 @@ list(APPEND hhctrl_rc_deps
     ${CMAKE_CURRENT_BINARY_DIR}/hhctrl_tlb.tlb)
 
 set_source_files_properties(hhctrl.rc PROPERTIES OBJECT_DEPENDS "${hhctrl_rc_deps}")
-
-# hhctrl_tlb.tlb needs stdole2.tlb
-add_dependencies(hhctrl stdole2)
-
 set_module_type(hhctrl win32ocx)
 target_link_libraries(hhctrl uuid wine)
 add_importlibs(hhctrl advapi32 comctl32 shlwapi ole32 oleaut32 user32 gdi32 msvcrt kernel32 ntdll)
-add_dependencies(hhctrl wineheaders)
+add_dependencies(hhctrl stdole2 wineheaders)
 add_pch(hhctrl hhctrl.h SOURCE)
 add_cd_file(TARGET hhctrl DESTINATION reactos/system32 FOR all)