[ICMP][IPHLPAPI] Move the icmp functions to iphlpapi where they belong. Brought to...
[reactos.git] / reactos / dll / win32 / icmp / CMakeLists.txt
index d231d3a..d36a089 100644 (file)
@@ -1,15 +1,12 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-spec2def(icmp.dll icmp.spec ADD_IMPORTLIB)
+spec2def(icmp.dll icmp.spec)
 
 list(APPEND SOURCE
-    icmp_main.c
     icmp.rc
     ${CMAKE_CURRENT_BINARY_DIR}/icmp_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/icmp.def)
 
 add_library(icmp SHARED ${SOURCE})
 set_module_type(icmp win32dll)
-target_link_libraries(icmp wine)
-add_importlibs(icmp ws2_32 msvcrt kernel32 ntdll)
+add_importlibs(icmp iphlpapi msvcrt kernel32 ntdll)
 add_cd_file(TARGET icmp DESTINATION reactos/system32 FOR all)