[CMAKE]
[reactos.git] / reactos / dll / win32 / itss / CMakeLists.txt
index 6e10707..32598b5 100644 (file)
@@ -13,19 +13,22 @@ list(APPEND SOURCE
     moniker.c
     protocol.c
     storage.c
-    rsrc.rc
     #${REACTOS_BINARY_DIR}/include/reactos/wine/itss_i.c
     ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
 
-add_library(itss SHARED ${SOURCE})
+add_library(itss SHARED
+    ${SOURCE}
+    rsrc.rc)
 
 set_module_type(itss win32dll)
 target_link_libraries(itss uuid wine)
 if(MSVC)
     target_link_libraries(itss itss_guid)
 else()
-    allow_warnings(itss)
+    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
+    #allow_warnings(itss)
+    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
 endif()
 
 add_importlibs(itss