[ITSS]
[reactos.git] / reactos / dll / win32 / itss / CMakeLists.txt
index 188c2c3..5d1e100 100644 (file)
@@ -2,8 +2,6 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-set_rc_compiler()
-
 spec2def(itss.dll itss.spec)
 
 list(APPEND SOURCE
@@ -13,26 +11,18 @@ list(APPEND SOURCE
     moniker.c
     protocol.c
     storage.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c)
+
+add_library(itss SHARED
+    ${SOURCE}
+    guid.c
     rsrc.rc
-    #${REACTOS_BINARY_DIR}/include/reactos/wine/itss_i.c
-    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
 
-add_library(itss SHARED ${SOURCE})
-
 set_module_type(itss win32dll)
 target_link_libraries(itss uuid wine)
-if(MSVC)
-    target_link_libraries(itss itss_guid)
-endif()
-
-add_importlibs(itss
-    urlmon
-    shlwapi
-    ole32
-    msvcrt
-    kernel32
-    ntdll)
-
+add_importlibs(itss urlmon shlwapi ole32 msvcrt kernel32 ntdll)
+add_pch(itss precomp.h SOURCE)
 add_dependencies(itss wineheaders)
 add_cd_file(TARGET itss DESTINATION reactos/system32 FOR all)