Start source tree (final, I hope!) restructuration. Part 1/X
[reactos.git] / reactos / dll / win32 / kernel32_vista / CMakeLists.txt
diff --git a/reactos/dll/win32/kernel32_vista/CMakeLists.txt b/reactos/dll/win32/kernel32_vista/CMakeLists.txt
deleted file mode 100644 (file)
index 7cdf538..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
-
-add_definitions(-D_KERNEL32_)
-spec2def(kernel32_vista.dll kernel32_vista.spec ADD_IMPORTLIB)
-
-list(APPEND SOURCE
-    DllMain.c
-    GetTickCount64.c
-    InitOnceExecuteOnce.c
-    ${CMAKE_CURRENT_BINARY_DIR}/kernel32_vista.def)
-
-add_library(kernel32_vista SHARED ${SOURCE})
-set_module_type(kernel32_vista win32dll HOTPATCHABLE ENTRYPOINT DllMain 12)
-add_importlibs(kernel32_vista kernel32 ntdll)
-add_dependencies(kernel32_vista psdk)
-add_cd_file(TARGET kernel32_vista DESTINATION reactos/system32 FOR all)