[LOCALSPL] Sync with Wine Staging 1.7.55. CORE-10536
[reactos.git] / reactos / dll / win32 / localspl / CMakeLists.txt
index e016604..e9c6970 100644 (file)
@@ -1,43 +1,25 @@
 
-add_definitions(-D__WINESRC__)
-
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
+add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
-set_rc_compiler()
-
 spec2def(localspl.dll localspl.spec)
 
 list(APPEND SOURCE
     localmon.c
     localspl_main.c
     provider.c
-    ${CMAKE_CURRENT_BINARY_DIR}/localspl_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/localspl.def)
+    localspl_private.h)
 
 add_library(localspl SHARED
     ${SOURCE}
-    localspl.rc)
+    localspl.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/localspl_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/localspl.def)
 
 set_module_type(localspl win32dll)
-
 target_link_libraries(localspl wine)
-
-add_importlibs(localspl
-    spoolss
-    user32
-    advapi32
-    msvcrt
-    kernel32
-    ntdll)
-
+add_importlibs(localspl spoolss user32 advapi32 advapi32_vista msvcrt kernel32 ntdll)
+add_pch(localspl localspl_private.h SOURCE)
 add_cd_file(TARGET localspl DESTINATION reactos/system32 FOR all)
-
-if(NOT MSVC)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    #allow_warnings(localspl)
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
-endif()
-