[MSVCRT]
[reactos.git] / reactos / dll / win32 / msvcrt / CMakeLists.txt
index 209877c..02d234a 100644 (file)
@@ -1,4 +1,5 @@
 
+include_directories(${REACTOS_SOURCE_DIR}/lib/sdk/crt/include)
 spec2def(msvcrt.dll msvcrt.spec ADD_IMPORTLIB)
 
 add_definitions(
@@ -11,30 +12,23 @@ add_definitions(
     -DCRTDLL
     -D__MINGW_IMPORT="")
 
-include_directories(${REACTOS_SOURCE_DIR}/lib/sdk/crt/include)
-
-set_rc_compiler()
-
 list(APPEND SOURCE
     dllmain.c
     stubs.c
     msvcrt.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/msvcrt_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/msvcrt.def)
 
 add_library(msvcrt SHARED ${SOURCE})
-
 set_module_type(msvcrt win32dll ENTRYPOINT DllMain 12)
-
 add_dependencies(msvcrt psdk)
-
 target_link_libraries(msvcrt crt wine ${PSEH_LIB})
 
 if(MSVC)
     # export of deleting destructor "name"
     add_target_link_flags(msvcrt "/ignore:4102")
+    add_target_property(libmsvcrt STATIC_LIBRARY_FLAGS "/ignore:4102")
 endif()
 
 add_importlibs(msvcrt kernel32 ntdll)
-add_pch(msvcrt precomp.h)
 add_cd_file(TARGET msvcrt DESTINATION reactos/system32 FOR all)
-