[NETAPI]
[reactos.git] / reactos / dll / win32 / netapi32 / netapi32.spec
index d15fb14..a07c78e 100644 (file)
@@ -1,10 +1,10 @@
 @ stub CredpValidateTargetName
 @ stdcall DsAddressToSiteNamesA(str long ptr str)
-@ stub DsAddressToSiteNamesExA
-@ stub DsAddressToSiteNamesExW
+@ stdcall DsAddressToSiteNamesExA(str long ptr str str)
+@ stdcall DsAddressToSiteNamesExW(wstr long ptr wstr wstr)
 @ stdcall DsAddressToSiteNamesW(wstr long ptr wstr)
-@ stub DsDeregisterDnsHostRecordsA
-@ stub DsDeregisterDnsHostRecordsW
+@ stdcall DsDeregisterDnsHostRecordsA(str str ptr ptr str)
+@ stdcall DsDeregisterDnsHostRecordsW(wstr wstr ptr ptr wstr)
 8 stdcall DsEnumerateDomainTrustsA(wstr long ptr ptr)
 9 stdcall DsEnumerateDomainTrustsW(wstr long ptr ptr)
 @ stub DsGetDcCloseW
 @ stub DsGetDcNextW
 @ stub DsGetDcOpenA
 @ stub DsGetDcOpenW
-@ stub DsGetDcSiteCoverageA
-@ stub DsGetDcSiteCoverageW
-@ stub DsGetForestTrustInformationW
+@ stdcall DsGetDcSiteCoverageA(str ptr str)
+@ stdcall DsGetDcSiteCoverageW(wstr ptr wstr)
+@ stdcall DsGetForestTrustInformationW(wstr wstr long ptr)
 @ stdcall DsGetSiteNameA(str str)
 @ stdcall DsGetSiteNameW(wstr wstr)
-@ stub DsMergeForestTrustInformationW
+@ stdcall DsMergeForestTrustInformationW(wstr ptr ptr ptr)
 @ stub DsRoleAbortDownlevelServerUpgrade
 @ stub DsRoleCancel
 @ stub DsRoleDcAsDc
@@ -36,8 +36,8 @@
 @ stub DsRoleIfmHandleFree
 @ stub DsRoleServerSaveStateForUpgrade
 @ stub DsRoleUpgradeDownlevelServer
-@ stub DsValidateSubnetNameA
-@ stub DsValidateSubnetNameW
+@ stdcall DsValidateSubnetNameA(str)
+@ stdcall DsValidateSubnetNameW(wstr)
 @ stub I_BrowserDebugCall
 @ stdcall I_BrowserDebugTrace(wstr str)
 @ stdcall I_BrowserQueryEmulatedDomains(wstr ptr ptr)
 @ stdcall NetFileGetInfo(wstr long long ptr)
 @ stdcall NetGetAnyDCName(wstr wstr ptr)
 @ stdcall NetGetDCName(wstr wstr ptr)
-@ stub NetGetDisplayInformationIndex
+@ stdcall NetGetDisplayInformationIndex(wstr long wstr ptr)
 @ stdcall NetGetJoinInformation(wstr ptr ptr)
 @ stdcall NetGetJoinableOUs(wstr wstr wstr wstr ptr ptr)
 @ stdcall NetGroupAdd(wstr long ptr ptr)