[CMAKE]
[reactos.git] / reactos / dll / win32 / riched20 / CMakeLists.txt
index 3f2c4e6..9a2e48b 100644 (file)
@@ -28,7 +28,7 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/riched20.def)
 
 if(MSVC)
-    if (ARCH MATCHES i386)
+    if(ARCH STREQUAL "i386")
         list(APPEND SOURCE msvc-thiscall.c)
     endif()
     set_source_files_properties(txthost.c txtsrv.c PROPERTIES COMPILE_FLAGS "/FImsvc.h")